User Guide

Moving Ouvvi with a New Database

There are two ways to export and import your Ouvvi site.

  • The Ouvvi Solution Import/Export
  • The Standard Ouvvi Import/Export

The solution Import/Export enables you to export your full Ouvvi configuration including your connection library, user settings and triggers alongside your groups and projects.

The standard import/export only enables you to export Projects and Connections. You can export projects from the project page, and connections from the specific connection page.

The solution export is available from Ouvvi 4.0.574, so if you are using a version before this you will need to use the standard import method.

Contents

  1. Create the New Ouvvi Tenant
  2. Solution Export/Import
  3. Simple Export/Imports
  4. Considerations

Create the New Ouvvi Tenant

You need to start by creating a new Ouvvi Tenant in the location you need it. To create a new tenant, for this we can take the default install or we can create one.

To create a new Ouvvi Tenant within the Deployment Manager choose File > New Tenant. To accept the default install just click OK on the popup that appears when you first open the Deployment Manager.

New Tenant

Install IIS components

Before installing Ouvvi you will first need to ensure that the default IIS configuration is installed. To do this go to Tools -> Install IIS Components.

This will run a PowerShell Script to install the required IIS Components.

Install IIS

Install SQL Server

Ouvvi requires a SQL Server to run and store all of the necessary project files. It can be run on all editions of Microsoft SQL Server, from SQL Express through to Enterprise Edition.

SQL Express is typically used to deploy Ouvvi unless you have an existing SQL Server.

To download SQL Server Express edition go to Tools -> Download SQL Express which will begin the download of the SQL installer. Please note that this will open a command window whilst it downloads.

Install SQL Express

Once this has downloaded the SQL Server setup window will open. Run through this changing any of the settings if you need to, otherwise you can keep clicking next until the installation is complete.

Configuration

You now need to configure the tenant settings before installing, to do this double click onto the tenant to open the configuration window where you can set the configuration settings for your tenant; such as the Tenant Name, Tenant Path and the Site Port you wish to use to browse to your Ouvvi site.

Please note that a random IIS Port will be assigned by default when you add a new Tenant so you may wish to change this to be a different port. If you plan to make Ouvvi available externally from this server be sure to configure SSL/TLS in IIS after you install this instance to keep your instance secure.

If your SQL Server is on another machine you should configure a Windows Service Account that will be the IISAppPool Identity used to authenticate with your SQL Database.

The default NT AUTHORITY\NETWORK SERVICE is a machine account and can be used when you have a single server set-up. i.e. Ouvvi Website, Service and Database are all on the same server.

Configuration

Database Setup

You now need to point the configuration to the SQL Server that will host your Ouvvi Database under the Database tab.

Enter the path to the SQL Server instance and then select the Ouvvi database from the drop down options.

SQL Authentication is only required when you cannot use Integrated Security and is not recommended unless this is your only option. Therefore, SQL Authentication is usually left blank.

The install will add the IISAppPool identity as DBO to the Ouvvi Database only when creating the Database. If you attach to an existing database ensure that the IISAppPool identity has permission to access the SQL Database.

If your SQL Server supports connection encryption make sure to set the Encrypt and Trust Server Certificate settings appropriately for your SQL Server connection.

Database Configuration

Service Setup

The Ouvvi Windows Service should be configured to run under a network domain account as this account will be used as the security context to run the steps within Ouvvi.

The default account NT AUTHORITY\NETWORK SERVICE is a machine account and can be used to access local machine resources and internet based services with a username and password. For Local Domain services SQL Servers, SharePoint Servers, FileShares etc a Domain User account must be used.

If you decide to change this from the default you will need to ensure that the service account has Admin+Agent permission set in Ouvvi. For more information on how to set admin and agent permissions please visit the Agents page.

Service Configuration

Install Ouvvi

The next step is to install your tenant. To do this right click onto your tenant and choose Install.

Install

Then browse to your Ouvvi site by right clicking and choosing Browse.

Browse

If you are getting permission errors then please check that the service account has read/write permissions within the Ouvvi database.

Now go back to the deployment manager and start your services. You can do this either by clicking the green play button in the menu or by right clicking on your instance and selecting Start Service from the list.

Start Services

Start Service from Menu

And then browse to your Ouvvi site to confirm all services are running correctly. Make sure to input your license key under Settings -> Register License otherwise your projects will not run once they have been imported.

Solution Export/Import

The solution export creates a zip folder containing all of the details you selected to be included about your Ouvvi tenant configuration. By default everything is selected however you can exclude items you do not want to include.

Export

To Export your Ouvvi site using the solution export go to Projects > All and select the Export button in the toolbar.

Export

Then click onto the Solution Export link to configure what to include in your export.

Open Solution Export

To include your connection library and user settings in the export make sure to check the checkboxes, and then decide if you want to include all projects or just a select few. To select all projects check the checkbox at the top of the list. Once you have everything checked click on the Export button to download the solution file.

Export Config

Import

To import the solution file you just downloaded you need to open the new Ouvvi tenant and go to Projects > All and select the Import button from the toolbar.

Import

Then click onto the Solution Import link to open the solution import.

Open Solution Import

Browse for the file by clicking onto Choose File and then click Next.

Select File

You can then preview what is included in the import and uncheck any checkboxes against items you do not want to import. When you are ready click Import to import the projects, triggers, groups, connections and settings.

Solution Import

You should now be able to view and run your projects.

Simple Export/Imports

If you are running old versions of Ouvvi that do not have the solution export then you will need to export the projects from your existing Ouvvi and then import them into the new Ouvvi tenant.

Triggers and Connection will need to be handled one item at a time.

You can use this option instead of the solution export to export your projects, triggers and connections.

Export & Import Projects

To export projects you can go to the projects overview page and click Export.

Export

Select the projects you want to export and then scroll to the bottom of the page and click the Export button. This will download an OPR file that you will need to upload into your new Ouvvi.

To import the OPR file you just downloaded, browse to your Ouvvi site and click onto Projects > All. Now click onto the Import button in the menu and then browse for the file to upload by clicking onto Choose File.

Import

Import Project

Clicking next will then load the file with your project configurations. You can then move on to exporting the connections in your Connection Library.

Export & Import Connections

To export a connection from the Connection Library you need to click onto that connection and select Download Connection File.

Export Connection

This will download a DSConn file that you can upload to your new Ouvvi Tenant.

To upload a connection go to the Connection Library and click Upload Connection.

Import Connection

Browse for the .dsconn file that you downloaded and click save. This will then load your connection into the Connection Library. Repeat this for any other connections you need to add.

The connections will then be available to use in your Ouvvi projects, triggers and settings.

Considerations

Services

If your services are registered to a particular machine then you will need to update the server name in the Ouvvi database in the services table.

Using a . as the service name assumes that it is the local machine.

If you use a specific name, you need to ensure that the machine you are on can access that machine.

The services talk to the web application so if the services are on another machine then the web app needs to be made public in order to connect. Without the services your projects will not run.

If the web application is made public but it is not a private network then you must install an SSL certificate in IIS.

Projects running in two locations

If you point your new instance to an existing database or import the projects make sure to stop the services on the old tenant so that the projects do not run in two locations.

Running the same project in two locations can lead to data loss and data being overwritten. Making sure that you only run the projects in one location saved you from lots of future issues.

ThisServiceEndpoint

This is a setting in user settings which isn't commonly used but you may be using it. It points to the URL of the ouvvi instance. If your database is now on a different machine or your Ouvvi site is using a different port then this will need updating. This can be updated in the User Settings table in the Ouvvi Database.

Alternatively you can remove it from the import when you are using the solution import.