Ouvvi License Invalid (TLS)

29 May 2020

I'm running an old version of Ouvvi and Data Sync and when I try to enter my license key I am getting the license key not valid error when the license key is entered. How do i fix this?

  1. For those that are on post .Net 4.6.2 version and may have upgraded in the past before the deployment manager where web config is not updated.

We have had to upgrade our TLS version on our server to version 1.2 as version 1 and 1.1 are seen as insecure and have been deprecated by Microsoft.

We believe we found that in some older versions of Ouvvi it's defaulting to .NET 4.5 which doesn't support TLS 1.2.

So we have a simple fix for this, if you could open the web.config file in a text editor from your tenant folder and add the targetFramework="4.6.2" attribute to the httpRuntime element.

Attached is a screenshot showing what needs to be changed below is a copy of what this element should contain.

httpRuntime requestValidationMode="2.0" targetFramework="4.6.2" />

The Web.config file will be in a path similar to C:\OuvviTenants\Default\Web\Web.config depending where you installed the Tenant files.

Webconfig Update

  1. For those pre .Net4.6.2 (before mid 2018) they need to upgrade to the latest version and this will fix the problem. If you cannot upgrade right now then offline license file will fix.